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Getting Started with P4V
P4V, the Perforce Visual client, is Perforce’s cross-platform graphical user interface. You 
can use P4V on Windows, Macintosh, UNIX and Linux computers and benefit from an 
identical interface regardless of platform. This introductory guide provides some Perforce 
basics and an orientation to P4V’s layout and features. For more details about P4V, 
consult its online help. To learn more about Perforce, consult the user documentation on 
our Web site.

To use Perforce to manage files, you typically connect to a Perforce server using a client 
program like P4V. P4V enables you to check files in and out, and perform the various 
other necessary tasks. The following sections tell you how to perform basic tasks and 
point out powerful features and shortcuts.

Basic Concepts

P4V connects your computer to a Perforce server to move files between Perforce depots and 
your workspace, as shown below.

The definitions for these Perforce terms are as follows:

• Workspace: folders or directories on the client computer where you work on revisions 
of files that are managed by Perforce. 

• Client application: P4V (or another Perforce client application), running on your 
computer, sending commands to the Perforce server and receiving results (files, status 
information, and so on).

Workspaces store 
local copies of files 
on...

...your computer, 
running P4V, which 
connects to...

...the Perforce Server 
on a central server 
machine, which 
manages...

...depots, repositories 
of files under 
Perforce control

(workspace)

(client application) (server)

(depot)
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Connecting to a Server
• Server: the program that executes the commands sent by client programs, maintains 
depot files, and tracks the state of workspaces. The Perforce Server typically runs on a 
central machine, connected to client machines by the network.

• Depot: a file repository on the Perforce server. It contains all existing versions of all files 
ever submitted to the server. There can be multiple depots on a single server. The 
examples in this guide show a single depot.

Connecting to a Server

To gain access to your depots, you must connect to a server. The first time you launch 
P4V, the Connection Setup Wizard (Macintosh: Connection Setup Assistant) guides you 
through the process of configuring a connection, during which you specify the server, 
user, and workspace. To launch the wizard/assistant in subsequent sessions, choose 
Connection > Set Up Connection...

Alternately, you can configure connection settings on a single dialog, as follows:

1. Launch P4V. P4V displays the following connection dialog:

2. Specify the following settings (your Perforce administrator can provide you with this 
information)

• Server: the name of the computer where your Perforce server is running.

• Port: the port number assigned to the server

• User: your Perforce user name

• Password: your Perforce user password, if required.

• Workspace: the name of your client workspace.

To display a list of existing users and workspaces, click Browse. (The server and 
port must be specified before clicking Browse.)
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Connecting to a Server
If you have incorrectly specified a server setting, P4V displays a message like the 
following:

3. To connect, click OK. P4V displays its main screen, as shown in the following figure.

The next section describes the main screen panes.

Connect to server failed; check $P4PORT.
TCP connect to bigserver failed.
bigserver: host unknown.
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Navigating the Main Screen
Navigating the Main Screen

The following figure points out the panes and important features of the main screen. To see 
what a button or screen element does, hold the mouse cursor over it. P4V displays a 
descriptive tooltip.

Toolbar buttons
switch panes

Right pane 
displays details
about selected 
objects

Log pane lists server commands;
Dashboard shows status and task shortcuts

Left pane displays
files and folders in
depot and workspace
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Setting up your workspace
Setting up your workspace

Your Perforce administrator can do this for you, but it’s advisable to learn a few important 
aspects of configuring your workspace, specifically (1) configuring the client root 
directory and (2) configuring the client view.

To define a workspace, choose Connection > New Workspace.... and, when prompted, 
enter a name for the workspace. To edit your current workspace specification, choose 
Connection > Edit Current Workspace... 

P4V displays the specification details in the lower portion of the right pane; for example:

Root: specifies the location 
on your computer under 
which Perforce stores 
copies of depot files. Specify 
a meaningful name, and 
make sure it’s not set to 
your computer’s root 
directory!

Workspace Mappings: 
enables you to restrict the 
depot files to which you 
have access. Set the view to 
ensure that you see only 
what you need to see.
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Setting up your workspace
To display and set the client view graphically, click the Basic tab. Browse to desired files 
and folders and context-click to include them or exclude them from the workspace 
mappings, as shown in the following figure.
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Managing your Files
Managing your Files

To manage files using Perforce, you typically perform the following sequence of tasks:

1. Get files from the depot.

2. Check out files you need to edit.

3. Edit files.

4. Check in your changes.

The following sections provide details about these and other common file management 
tasks.

Getting files from the depot

To copy files from the depot to your workspace:

1. In the left pane, click the Depot tab.

2. Browse to the folder or file you want to retrieve.

3. Context-click the file or folder. To get the most recent version, choose Get Latest 
Revision. To get an older version, choose Get Revision... and specify the version you 
want. 

In the Log pane, P4V displays a message like the following.

In the left pane, note that the files display green dots, indicating that they are present in 
your workspace: Before you can edit the file, however, you must check it out.

p4 sync //depot/Misc/manuals/...#head
//depot/Misc/manuals/recommended_configuration.doc added c:\p4cli

ents\bruno-1492\Misc\manuals\recommended_configuration.doc
//depot/Misc/manuals/triggers.doc added c:\p4clients\bruno-

1492\Misc\manuals\triggers.doc
//depot/Misc/manuals/vendor_branches.doc added c:\p4clients\bruno

-1492\Misc\manuals\vendor_branches.doc
Sync copied 3 files to workspace (including 3 that were added)
Sync removed no files from workspace

Sync completed with no warnings or errors.
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Managing your Files
Checking out files from the depot

To check out a file in your workspace:

1. Browse to the desired file in the left pane Depot tab. 

2. Context-click the file and choose Check Out.

In the Log pane, P4V displays a message like the following:

In the left pane, note that the file displays a red check mark, indicating that you checked it 

out:

Note that, when you check out a file, Perforce adds it to a changelist, which is a list of 
related files. You can use changelists to group related files, for example, all files that 
contain changes required to implement a new product feature. To view the changelist, 
choose View > Pending Changelists or click in the toolbar.

Now you’re ready to edit your files.

Editing files in your workspace

To edit a checked-out file, double-click it (or context-click it and choose Open With, then 
select the desired application). P4V launches the corresponding editing application. Make 
changes and save the file. 

To select an application with which to open a file, choose File>Open With>Choose 
Application. Note that you can configure editors on the Preferences dialog Editors tab. 

p4 edit //bruno-1492/Misc/manuals/recommended_configuration.doc
//depot/Misc/manuals/recommended_configuration.doc#1 - opened for 

edit
Opened 1 files for edit
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Managing your Files
Diffing files to view your edits

To enable you to see what changes you’ve made, you can compare (diff) your edited file 
with the version you checked out. To diff, context-click the checked-out file in the left 
pane and choose Diff Against Have Revision. P4V launches the diff tool, displaying the 
differences between the two files. For example:

Discarding edits by reverting

If you decide you want to discard your changes:

1. Context-click the file in the left pane and choose Revert. P4V displays a warning 
dialog. 

2. Click OK. In the Log pane, P4V displays a message like the following:

p4 revert //depot/Misc/manuals/recommended_configuration.doc
revert complete. 1 file affected.
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Managing your Files
Checking your edits into the depot

To check your changed file into the depot, perform the following steps.

1. Display pending changelists: click in the toolbar. P4V displays a list of pending 
changelists, as shown in the following figure. To display the files in a changelist, 
expand it

2. Double-click the changelist in which your file is open. P4V displays the details, as 
shown in the following figure.
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Graphical Reporting Tools
3. Enter a description explaining the changes you made and click Submit. The Log 
pane displays a message confirming that your changelist was submitted, similar to 
the following.

Displaying a file’s revision history

To view the changes made to a file or folder, context-click the file or folder and choose File 
History or Folder History. The history for the selected file or folder is displayed in the 
right pane. For example, the following figure shows the history of a folder, listing every 
submitted changelist that affected a file in the folder.

Graphical Reporting Tools

P4V includes several valuable graphical reporting tools:

• Revision Graph: displays a diagram that shows the evolution of a selected file, 
including files related by branching operations.

• Time-lapse View: shows how the contents of a selected text file changed from revision 
to revision. You can easily sweep through revision ranges to locate passages of interest 
and see when they were created and how they changed.

• Folder diff tool: enables you to see how the contents of a folder changed.

The following sections provide more details about these tools.

Change 813 submitted.
submit complete. 1 file affected.
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Graphical Reporting Tools
Viewing file revisions as a diagram

To display the revision diagram for a file, context-click the file in the left pane and choose 
Revision Graph. P4V launches the tool, which displays a diagram like the following one.

This diagram shows you when the file was created and how it was branched, and enables 
you to view details about each version submitted to the depot and navigate through the 
graph using the navigation map. For more details about the information displayed in the 
revision graph, consult P4V online help.
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Graphical Reporting Tools
Browsing file revisions using Time-lapse View

To browse the changes made to a text file, context-click the file in the left pane and choose 
Time-lapse View. P4V launches the utility, which displays a screen like the following one. 

Using Time-lapse View, you can sweep through all revisions of the file using the slider, 
noting when changes were made and who made them. Again, for details, consult P4V 
online help.

Displaying folder history using the folder diff tool

The folder diff tool enables you to see how the contents of a folder have changed: which 
files have been added, changed, or deleted. To view changes to a folder:

1. Context-click the folder in the left pane Depot or Workspace tab and choose Folder 
History. In the right pane, P4V lists changelists that affected the folder, for example:

2. To display the changes that occurred between two revisions of a folder, drag and 
drop one of the revisions on the other. 

Change detail: shows 
text that has been 
added, changed, or 
deleted in a revision

Slider: move to sweep 
through revisions
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Graphical Reporting Tools
P4V displays the changes as shown in the following figure. This example shows that, 
between the selected revisions, a file was edited and checked in. File highlights are color-
coded to indicate additions, changes, and deletions. Expand folders and scroll to locate 
changes of interest. To skip to the next or previous change, click the right and left arrows. 

Click these arrows to browse changes.
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Viewing Streams
Viewing Streams

Perforce streams are “branches with brains,” a containerized approach to managing 
bodies of related files such as codelines. If your organization uses streams, you’ll see 
streams depots in the Depot pane. Streams depots look like this: . To display the 
streams in the depot:

1. Click the Streams toolbar button: . The Streams tab is displayed.

2. To display a diagram of the stream hierarchy, choose the graph view: 

3. Choose the streams depot that you want to view. P4V displays the stream graph, 
which shows the parent/child relationships and status of the streams; for example:

For detailed information about streams in P4V, consult the online help. For general 
information, see Introducing Perforce, the P4 User’s Guide and the Perforce Command 
Reference.
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Important and Useful Features
Important and Useful Features

Among the many features provided by P4V, the following are especially useful:

• Tooltips: to get more information about an object, place your mouse cursor over it. P4V 
displays a popup dialog containing more details.

• Drag and drop: P4V includes numerous drag and drop shortcuts for common 
operations.

• File views: P4V enables you to preview graphics files using thumbnails.

• Tear off windows: to create a separate window displaying a specification you want to 
keep on display, you can tear it off.

The following sections provide more details.

Tooltips

P4V provides tooltips for many objects on the screen. For example, to display the status of 
a file, hold the mouse cursor over the file in the left pane. P4V displays a tooltip like the 
following one.

Another example: to display a changelist description, click in the toolbar and hold the 
mouse cursor over the changelist in the right pane. There are tooltips for all the P4V 
buttons, too.

Drag and drop

P4V provides drag and drop shortcuts for common tasks. Drag and drop can simplify 
operations on large groups of files. For example, to check out all the files in a folder, drag 
the folder to a changelist. To diff two files, drag one to the other. For details about drag 
and drop shortcuts, refer to the P4V online help.
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Important and Useful Features
File views

If you use Perforce to manage graphics files, P4V’s thumbnail views enable you to 
preview the files. To display thumbnails, click the Files tab in the right pane, then select 
the desired thumbnail size from the title bar.

P4V displays thumbnails as shown in the following example.
Perforce 2011.1 Getting Started with P4V 21



Important and Useful Features
Undocking tabs

To keep a tab open, you can undock it. For example, context-click a file and choose File 
History, then choose Window > Undock Tab. P4V opens a separate window for it, as 
shown in the following figure.

To restore it to the main window, choose Window > Dock Window.

Setting Preferences

To configure P4V, edit its preferences (Mac: P4V > Preferences, Windows: File > 
Preferences). The Editor tab enables you to associate applications with file types, 
overriding any operating system associations. The Diff and Merge tabs enable you to 
configure external applications, in case you prefer tools other than those that are bundled 
with P4V.
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Migrating from P4Win
Migrating from P4Win

If you’re moving from P4Win to P4V, here’s a list of equivalent operations to help you in 
your transition.

P4Win Menu Item Menu P4V Menu Item Menu Notes

Add to Source 
Control...

File Mark for Add Actions Applies only 
to files in the 
Workspace 
Tree

Annotate File... File Time-lapse View Tools Graphical 
annotation 
tool

Diff 2 Files, 
Folders or 
Revisions

File Diff... Tools

Diff Client File 
vs. Depot File

File Diff... Tools Or context- 
click on file 
and choose:
Diff Against 
Have 
Revision

Explore File Show in>Explorer File

Integrate Using 
Filespec or 
Branchspec

File Integrate... Actions

Open for Delete File Mark for Delete Actions

Open for Edit File Check Out Actions

Properties File Files in Folder View File properties 
are displayed 
in the Details 
pane at the 
bottom of the 
Files in Folder 
view

Remove from 
Client

File Remove from 
Workspace

Actions

Rename File Rename/Move... Actions
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Migrating from P4Win
Revision 
History...

File History View Alternatively 
context click 
on file and 
choose File 
History

View File… File Open File Alternatively 
context click 
on file and 
choose Open

Check 
Consistency

File>More Reconcile Offline 
Work...

Actions Applies only 
to folders in 
the 
Workspace 
Tree

Auto Resolve... File>Resolve Resolve… Actions

Interactively... 
[Resolve]

File>Resolve Resolve… Actions

Schedule File for 
Resolve

File>Resolve Get Latest Revision Actions

Sync to Head 
Revision

File>Sync Get Latest Revision Actions

Sync... File>Sync Get Revision... Actions

Find File 
Matching 
Pattern…

Edit Find File... Edit

Find File Under 
Selected Folder...

Edit Find File... Edit

Bookmarks View Bookmarks Tools

Client View of 
Depot

View Depot Tree View Restrict to 
client view by 
choosing:
View>Filter 
Depot>Tree 
Restricted to 
Workspace 
View

ClientSpecs View Workspaces View

P4Win Menu Item Menu P4V Menu Item Menu Notes
24 Perforce 2011.1 Getting Started with P4V



Migrating from P4Win
Describe (any 
specification 
menu)

Go To... Edit Navigate 
directly to 
desired 
specification

Entire Depot View Depot Tree View Show the 
entire depot 
by choosing:
View>Filter 
Depot>Entire 
Depot Tree

Local View of 
Client Tree

View Workspace Tree View

Show Deleted 
Depot Files

View Show Deleted 
Depot Files

View>Filter 
Depot

Favorite 
Connections

Settings Favorite 
Connections

Connection

Logout Settings Log Off Connection

Options... Settings Preferences... Edit

Port Client User 
History

Settings Open Recent Connection

Switch Port 
Client User...

Settings Open Connection... Connection

Set Password for 
(current user)...

User Change Password... Connection

View Users User Administration Tools Superusers 
can manage 
users and 
groups from 
within P4V

P4Win Menu Item Menu P4V Menu Item Menu Notes
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Next Steps
Next Steps 

This guide helps you to start working with files using P4V and points out important basic 
features, but P4V enables you to do much more: create jobs, branch groups of files, and 
handle file conflicts that arise in team development settings. 

Perforce administrators can perform administrative operations by choosing Tools > 
Administration. Using the Administration tool, superusers can manage users and groups, 
and their access to files and folders within the depot. Some administrative functions must 
still be performed using the Perforce command-line client (p4). For details, see the Perforce 
Command Reference and the Perforce System Administrator’s Guide. 

To become expert with P4V:

• Consult the P4V online help and read the Perforce user documentation available from 
the Perforce Web site.

• Use tooltips.

• Pay attention to the file icons and decorations in the left pane. The decorations and 
icons display a great deal of information about the type and status of a file. 

• Start reading the Log pane.

• Learn drag and drop shortcuts to simplify operations on large sets of files.

• Use P4V views and filtering features to enable you to selectively display information.

To get the whole picture, read the P4V online help, Introducing Perforce and the Perforce 
System Administrator’s Guide. The guides, which are available from the Perforce web site, 
describe the full set of features that the Perforce Server provides. Perforce Technical 
Support is always ready to help you, and there’s a thriving community of Perforce users 
active on the perforce-user mailing list. Consult our web site for details.
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